<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"r0rrvMTr7WCp9r",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"kait"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "kait/web/politics/national",
    "authors": [
                  
                    {
                      "_id": "",
                      "name": "EMILY WAGSTER PETTUS",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2018/11/14/challenger-senator-mississippi-hanging-comment-harmful/",
    "contentId": "DH2AHXPOZJGCBPLEDOH3BRNUYA",
    "contentName": "Challenger: Mississippi senator's 'hanging' comment harmful",
    "contentOwner": "raycom",
    "contentTags":  [
                  
                ],
    "contentType": "story",
    "datePublished": "2018-11-14T22:29:32.196Z",
    "description": "A black Democratic challenger says a white Republican U.S. senator from Mississippi needs to fully explain her comment about a &quot;public hanging.&quot;",
    "hasVideo": "false",
    "metaDescription": "A black Democratic challenger says a white Republican U.S. senator from Mississippi needs to fully explain her comment about a &quot;public hanging.&quot;",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "National",
                            "_id": "/politics/national",
                            "path": "/politics/national",
                          }
                        
                      ,
    "publishedDay": "14",
    "publishedMonth": "11",
    "publishedYear": "2018",
    "stationName": "kait",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="sKiWVpF1B8xon1FyiyR9SfMIyuoRn0fwtKIcSdB3_f4"/> <title>Challenger: Mississippi senator&#039;s &#039;hanging&#039; comment harmful</title> <meta name="keywords" content="US,, Election 2018, Senate, Mississippi"> <meta name="news_keywords" content="US,, Election 2018, Senate, Mississippi"/> <meta name="date" content="2018-11-14T22:29:32.196Z"/> <meta itemprop="description" name="description" content="A black Democratic challenger says a white Republican U.S. senator from Mississippi needs to fully explain her comment about a &quot;public hanging.&quot;"/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="/2018/11/15/challenger-mississippi-senator-hanging-comment-harmful/"> <meta name="twitter:title" content="Challenger: Mississippi senator's 'hanging' comment harmful"/> <meta name="twitter:image" content="http://www.kait8.com/resizer/xWv-BMQaMiOyjDpuSKeYVnIrcT4=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/GMIHGXLPYJGRRN2UJRIEIATLFM.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="A black Democratic challenger says a white Republican U.S. senator from Mississippi needs to fully explain her comment about a &quot;public hanging.&quot;"/> <meta name="twitter:site" content="@Region8News"/> <meta name="twitter:creator" content="@Region8News"> <meta property="og:url" content="/2018/11/15/challenger-mississippi-senator-hanging-comment-harmful/"/> <meta property="og:title" content="Challenger: Mississippi senator's 'hanging' comment harmful"/> <meta itemprop="image" property="og:image" content="http://www.kait8.com/resizer/xWv-BMQaMiOyjDpuSKeYVnIrcT4=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/GMIHGXLPYJGRRN2UJRIEIATLFM.jpg"/> <meta property="og:description" content="A black Democratic challenger says a white Republican U.S. senator from Mississippi needs to fully explain her comment about a &quot;public hanging.&quot;"/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="http://www.kait8.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="213753052169397"/> <meta property="fb:pages" content="87689783147"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/Region8News"> <link rel="amphtml" href="/2018/11/15/challenger-mississippi-senator-hanging-comment-harmful/?outputType=amp"> <meta name="author" content="EMILY WAGSTER PETTUS"> <script data-schema="NewsArticle" type="application/ld+json">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</script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "http://www.kait8.com",
        "logo": "http://www.kait8.com/pb/resources/images/rm_icons/kait-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/Region8News" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-frameworkd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/kait-logo.svg?v=36)}</style> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-frameworkd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-featuresd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-servicesd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <script async src="/pb/resources/dist/d404f83286001ac73b19/rm/rm-indexd404f83286001ac73b19.js?v=36"></script> <script src="/pb/gr/c/default/r0rrvMTr7WCp9r/arcAdsJS/84612eb819.js?v=36"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="fNvIO82s7WCp9r"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kait8.com/business/legal/ask-the-attorney/" class="color-grey-dark">Ask The Attorney</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://region8connect.revrocket.us/n/#!/home" class="color-grey-dark">Region 8 CONNECT</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kait8.com/community/gr8-acts-of-kindness/" class="color-grey-dark">GR8 Acts of Kindness</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kait8.com/food" class="color-grey-dark">Region 8 Eats</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kait8.com/education/teacher-of-the-year/" class="color-grey-dark">Teacher of the Year</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kait8.com/community/energy-alert/" class="color-grey-dark">Energy Alert</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kait8.com/home-pros/" class="color-grey-dark">Home Pros</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f5REg52s7WCp9r"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="fRfYK81s7WCp9r"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.kait8.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.kait8.com/video-gallery" class="">VIDEO</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/health" class="">Health</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/community" class="">Community</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/contests" class="">Contests</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.kait8.com/programming/schedule/" class="">WHAT'S ON</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/homepage" class="color-white">Home</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kait8.com/live" class="color-white">Region 8 News Live and Replay</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.kait8.com/apps" class="color-white">Region 8 Digital Apps</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.kait8.com/community/user-content/" class="color-white">See It - Snap It - Send It</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="http://www.kait8.com/video-gallery" class="color-white">Recent Video</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="http://www.kait8.com/tips/" class="color-white">Submit a News Tip</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news" class="color-white">News</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/news/state" class="color-white">State</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/news/national" class="color-white">National</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/entertainment" class="color-white">Entertainment</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/education" class="color-white">Education</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/news/crime" class="color-white">Crime</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/politics" class="color-white">Politics</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/business" class="color-white">Business</a> </li> <li class="list-unstyled padded padded-sm padded-right li-10"> <a href="/news/consumer" class="color-white">Consumer</a> </li> <li class="list-unstyled padded padded-sm padded-right li-11"> <a href="/news/technology" class="color-white">Technology</a> </li> <li class="list-unstyled padded padded-sm padded-right li-12"> <a href="/news/oddities" class="color-white">Oddities</a> </li> <li class="list-unstyled padded padded-sm padded-right li-13"> <a href="/news/editorial" class="color-white">A Better Region 8</a> </li> <li class="list-unstyled padded padded-sm padded-right li-14"> <a href="/traffic/gas-prices" class="color-white">Pump Patrol</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/weather" class="color-white">Weather</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/weather/cams" class="color-white">Skycams</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.kait8.com/weatheralerts/" class="color-white">Weather Alerts</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.kait8.com/health/allergies/sneezecast/" class="color-white">Sneezecast</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/weather/closings" class="color-white">Closings</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="http://www.kait8.com/weather/stormtracker/" class="color-white">Central Dealerships Storm Tracker</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="http://www.kait8.com/apps/" class="color-white">Download Apps</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/sports" class="color-white">Sports</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/sports/high-school/football" class="color-white">Football Friday Night</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/sports/ncaa/a-state" class="color-white">A-State Redwolves</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/ncaa/arkansas" class="color-white">Arkansas Razorbacks</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/nba" class="color-white">NBA</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/national" class="color-white">National</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/sports/outdoors" class="color-white">Outdoors</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/community" class="color-white">Community</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/community/religion-today" class="color-white">Religion Today</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/community/a-family-for-me" class="color-white">A Family for Me</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/midday-guests" class="color-white">Midday Guests</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/community/calendar" class="color-white">Calendar</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/pets" class="color-white">Pets</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="http://www.kait8.com/road-trip/" class="color-white">Road Trip</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/health" class="color-white">Health</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/health/medical-minute" class="color-white">NYIT Medical Minute</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/health/national" class="color-white">National</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/programming" class="color-white">Programming</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kait8.com/programming/schedule/" class="color-white">What's On KAIT</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.kait8.com/programming/me-time" class="color-white">Me Time With Frangela</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/about-us" class="color-white">About Us</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchKeyword=&searchLocation=-12785-Jonesboro&searchCategory=" class="color-white">KAIT Jobs</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/contests" class="color-white">Contests</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kait8.com/2018/11/05/paw-patrol-live-ticket-giveaway/" class="color-white">Paw Patrol Live Ticket Giveaway</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.kait8.com/2018/10/08/subway-standout-coach-contest/" class="color-white">Standout Coach Contest</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.kait8.com/2018/08/28/bartons-weather-umbrella-contest-entry/" class="color-white">Barton's Umbrella</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="http://www.kait8.com/2018/10/22/dwight-yoakam-ticket-giveaway/" class="color-white">Dwight Yoakam Ticket Giveaway</a> </li> </ul> </li> </ul> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0X0l7Ps7WCp9r"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-kait-breaking/" data-url="/pb/api/v2/render/feature" data-website="kait" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fKSiD82s7WCp9r"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/kait-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="kait"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fvqScP1s7WCp9r"> <div id="ad480-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad480" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad480",slotName:"kait/web/politics/national",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"DH2AHXPOZJGCBPLEDOH3BRNUYA"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="fN62IT1s7WCp9r"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Challenger: Mississippi senator's 'hanging' comment harmful</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="Challenger: Mississippi senator&#039;s &#039;hanging&#039; comment harmful" src="http://www.kait8.com/resizer/_XdRAeSO3HrYcizLcSuF6vPbFCc=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/GMIHGXLPYJGRRN2UJRIEIATLFM.jpg"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> Mike Espy who is seeking to unseat appointed U.S. Sen. Cindy Hyde-Smith, R-Miss., and serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons, speaks before the leadership of Working Together Jackson during their luncheon and accountability session, Wednesday, Nov. 14, 2018 in Jackson, Miss. (AP Photo/Rogelio V. Solis) (Rogelio V. Solis) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0HDvH2s7WCp9r"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Challenger%3A+Mississippi+senator%27s+%27hanging%27+comment+harmful&amp;url=http%3A%2F%2Fwww.kait8.com%2F2018%2F11%2F15%2Fchallenger-mississippi-senator-hanging-comment-harmful%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.kait8.com%2F2018%2F11%2F15%2Fchallenger-mississippi-senator-hanging-comment-harmful%2F&amp;title=Challenger%3A+Mississippi+senator%27s+%27hanging%27+comment+harmful', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=Challenger%3A%20Mississippi%20senator%27s%20%27hanging%27%20comment%20harmful&amp;body=Read%20more%20on%20Challenger%3A%20Mississippi%20senator%27s%20%27hanging%27%20comment%20harmful%20at%20http%3A%2F%2Fwww.kait8.com%2F2018%2F11%2F15%2Fchallenger-mississippi-senator-hanging-comment-harmful%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="far fa-envelope icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f4d0B72s7WCp9r"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <span class="font-bold color-black">EMILY WAGSTER PETTUS</span> <span class="font-bold">|</span> <span class="timestamp"> November 14, 2018 at 4:29 PM CST - Updated November 14 at 9:38 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f20gnB1s7WCp9r"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>JACKSON, Miss. (AP) — A white Republican U.S. senator from Mississippi needs to fully explain her comment about a "public hanging," her black Democratic challenger said Wednesday.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Republican Sen. Cindy Hyde-Smith made the remark in a video that surfaced Sunday. She praised a cattle rancher at a Nov. 2 campaign event in Tupelo by saying: "If he invited me to a public hanging, I'd be on the front row."</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Mississippi has a history of racially motivated lynchings.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Democrat Mike Espy said Wednesday in Jackson that Hyde-Smith's comment was "hurtful and harmful."</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad607-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad607" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad607",slotName:"kait/web/politics/national/DH2AHXPOZJGCBPLEDOH3BRNUYA",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"It was hurtful to Mississippians of good will who know better," said Espy, who is seeking to become Mississippi's first black U.S. senator since Reconstruction. "But it was also harmful because it reinforced all these negative stereotypes — the stereotypes that I've been working all my life to try to overcome."</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Republican U.S. Sen. Cindy Hyde-Smith of Mississippi appeared at a news conference at the state Republican Party headquarters in Jackson, Miss., on Monday, Nov. 12, 2018, and said repeatedly that she would not answer questions about a video that showed her at a Nov. 2 campaign event in Tupelo, Miss., where she praised a man by saying: &quot;If he invited me to a public hanging, I'd be on the front row.&quot; Hyde-Smith issued a statement Sunday saying the remark was &quot;an exaggerated expression of regard&quot; for a friend who invited her to speak, and &quot;any attempt to turn this into a negative connotation is ridiculous.&quot; Hyde-Smith was appointed to serve temporarily in the Senate after longtime Republican Sen. Thad Cochran retired in April, and she faces an African-American Democrat, Mike Espy, in a Nov. 27, 2018, runoff. Espy is a former congressman and former U.S. agriculture secretary. The runoff winner will serve the final two years of the six-year term started by Cochran. (AP Photo/Emily Wagster Pettus)" data-src="http://www.kait8.com/resizer/lCzNLHvSkBpXI01leyFMu-jtJ28=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CMWRSCZXZJBBHOCMH2WJYJ47AU.jpg" src="http://www.kait8.com/resizer/ZUh4iEsBfP3fHN9tUB3uA_W-eso=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CMWRSCZXZJBBHOCMH2WJYJ47AU.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Republican U.S. Sen. Cindy Hyde-Smith of Mississippi appeared at a news conference at the state Republican Party headquarters in Jackson, Miss., on Monday, Nov. 12, 2018, and said repeatedly that she would not answer questions about a video that showed her at a Nov. 2 campaign event in Tupelo, Miss., where she praised a man by saying: "If he invited me to a public hanging, I'd be on the front row." Hyde-Smith issued a statement Sunday saying the remark was "an exaggerated expression of regard" for a friend who invited her to speak, and "any attempt to turn this into a negative connotation is ridiculous." Hyde-Smith was appointed to serve temporarily in the Senate after longtime Republican Sen. Thad Cochran retired in April, and she faces an African-American Democrat, Mike Espy, in a Nov. 27, 2018, runoff. Espy is a former congressman and former U.S. agriculture secretary. The runoff winner will serve the final two years of the six-year term started by Cochran. (AP Photo/Emily Wagster Pettus) (AP) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Hyde-Smith, the first woman to represent Mississippi in either chamber of Congress, said in a statement Sunday that the hanging comment was an "exaggerated expression of regard" for a supporter and "any attempt to turn this into a negative connotation is ridiculous."</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>She would not answer reporters' repeated questions about it Monday during a news conference at the Mississippi Republican Party headquarters.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad182-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad182" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad182",slotName:"kait/web/politics/national",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"That was curious what she said. But even more than that, after being asked six times to explain it, clarify, whatever, she didn't," said Espy, who spoke to reporters after appearing at a luncheon sponsored by a nonpartisan group called Working Together Jackson.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1834-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1834" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1834",slotName:"kait/web/politics/national/DH2AHXPOZJGCBPLEDOH3BRNUYA",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Hyde-Smith was also invited to the luncheon, but she was in Washington because the Senate is in session. Her campaign did not respond to Espy's criticism Wednesday.</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Mike Espy who is seeking to unseat appointed U.S. Sen. Cindy Hyde-Smith, R-Miss., and serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons, speaks before the leadership of Working Together Jackson during their luncheon and accountability session, Wednesday, Nov. 14, 2018 in Jackson, Miss. (AP Photo/Rogelio V. Solis)" data-src="http://www.kait8.com/resizer/O9RxwsN4mwZt-dzA5-OR55YYxo8=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/4ONJG6DQ6RGV3GOS3MDNMTPJVA.jpg" src="http://www.kait8.com/resizer/-fF1VrAB4zwTk4Mu9qZdcswMDJ0=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/4ONJG6DQ6RGV3GOS3MDNMTPJVA.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Mike Espy who is seeking to unseat appointed U.S. Sen. Cindy Hyde-Smith, R-Miss., and serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons, speaks before the leadership of Working Together Jackson during their luncheon and accountability session, Wednesday, Nov. 14, 2018 in Jackson, Miss. (AP Photo/Rogelio V. Solis) (AP) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Hyde-Smith and Espy are competing in a Nov. 27 runoff, and the winner will get the final two years of a six-year term started by Republican Thad Cochran.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Republican Gov. Phil Bryant appointed Hyde-Smith to temporarily succeed Cochran when the longtime lawmaker retired in April.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Democrats haven't won a U.S. Senate seat in Mississippi since 1982, and Republicans hold most statewide offices. Both national parties are putting money and effort into the special election. Hyde-Smith and Espy each received about 41 percent in a four-person field Nov. 6 to advance to the runoff.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1665-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1665" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1665",slotName:"kait/web/politics/national/DH2AHXPOZJGCBPLEDOH3BRNUYA",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>President Donald Trump has endorsed Hyde-Smith and traveled to Mississippi to campaign for her in October. A person with knowledge of White House thinking who is not authorized to speak publicly said Wednesday that the White House is looking at holding a rally in Mississippi before the runoff, but plans are still not definite.</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Sen. Cindy Hyde-Smith, R-Miss., right, speaks with James Ball, left, and Sallie Vaughn as she campaigns Tuesday, Nov. 6, 2018, at Mama Hamil's Restaurant in Madison, Miss. (AP Photo/Rogelio V. Solis)" data-src="http://www.kait8.com/resizer/a-UMuAxvhmmIdqCgTUqrElSxYuU=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/HGCVQJLU5NDIZP6VNOQTVIDYNQ.jpg" src="http://www.kait8.com/resizer/CyEev3Jo9kgAjF_-1PQvKPGdhCA=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/HGCVQJLU5NDIZP6VNOQTVIDYNQ.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Sen. Cindy Hyde-Smith, R-Miss., right, speaks with James Ball, left, and Sallie Vaughn as she campaigns Tuesday, Nov. 6, 2018, at Mama Hamil's Restaurant in Madison, Miss. (AP Photo/Rogelio V. Solis) (AP) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Democratic U.S. Sen. Kamala Harris of California is scheduled to campaign for Espy on Saturday in Mississippi, Harris' spokeswoman said.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad1141-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1141" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1141",slotName:"kait/web/politics/national",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>In the late 1960s, Espy and his twin sister, Michelle, were among the 17 black students who integrated what had been a white public high school in their hometown of Yazoo City.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"It was W.E.B. Dubois that said the issue of the 20th century was the issue of the color line," Espy said Wednesday. "So, now it seems the issue of the 21st century is also the problem of the color line. I know here in Mississippi, we've had these issues all of my life. I was (called) the N word in high school because my twin sister and I — we were 17 black students in a student body of 800."</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad977-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad977" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad977",slotName:"kait/web/politics/national/DH2AHXPOZJGCBPLEDOH3BRNUYA",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Espy in 1986 became Mississippi's first black U.S. House member since Reconstruction. In 1993 and 1994, he was U.S. agriculture secretary.</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Mike Espy who is seeking to unseat appointed U.S. Sen. Cindy Hyde-Smith, R-Miss., and serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons, speaks before the leadership of Working Together Jackson during their luncheon and accountability session, Wednesday, Nov. 14, 2018 in Jackson, Miss. (AP Photo/Rogelio V. Solis)" data-src="http://www.kait8.com/resizer/UCes8GqHMSvwRRWnivtsLAwWvuo=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/SHTDJOBSJRH7XDAP5RR6HOWAZ4.jpg" src="http://www.kait8.com/resizer/i3Lfk0YAW7qAjht9grkKB4BSh10=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/SHTDJOBSJRH7XDAP5RR6HOWAZ4.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Mike Espy who is seeking to unseat appointed U.S. Sen. Cindy Hyde-Smith, R-Miss., and serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons, speaks before the leadership of Working Together Jackson during their luncheon and accountability session, Wednesday, Nov. 14, 2018 in Jackson, Miss. (AP Photo/Rogelio V. Solis) (AP) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Speaking of Hyde-Smith's "public hanging" remark, Espy said some politicians think apologizing is a form of weakness.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"I really think it's a sign of strength," Espy said. "I mean, nobody's perfect. Everyone makes mistakes. When you make mistakes, you've got to own up to it, and you ought to say, 'I'm sorry.'"</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>____</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Associated Press writer Catherine Lucey in Washington contributed to this report. For AP's complete coverage of the U.S. midterm elections: http://apne.ws/APPolitics . Follow Emily Wagster Pettus on Twitter: http://twitter.com/EWagsterPettus .</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-border-bottom card-border-bottom-thick card-border-bottom-darkcard-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Sen. Cindy Hyde-Smith, R-Miss., speaks to supporters of her campaign during an election night party she shared with fellow Republican U.S. Sen. Roger Wicker, right, in Jackson, Miss., Tuesday, Nov. 6, 2018. Hyde-Smith, who was appointed to the seat, is in a Nov. 27 runoff against Mike Espy in this non-partisan race. The winner will serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons. (Sarah Warnock/The Clarion-Ledger via AP)" data-src="http://www.kait8.com/resizer/YmKDiujYMLbI998JUyDr3GGwqn0=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UR5HX7G2LFCSNBXL3P26SFJ7HY.jpg" src="http://www.kait8.com/resizer/p_scHEoju0NhXFYlKxLKGIIjpo8=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UR5HX7G2LFCSNBXL3P26SFJ7HY.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Sen. Cindy Hyde-Smith, R-Miss., speaks to supporters of her campaign during an election night party she shared with fellow Republican U.S. Sen. Roger Wicker, right, in Jackson, Miss., Tuesday, Nov. 6, 2018. Hyde-Smith, who was appointed to the seat, is in a Nov. 27 runoff against Mike Espy in this non-partisan race. The winner will serve the last two years of the six-year term vacated when Republican Thad Cochran retired for health reasons. (Sarah Warnock/The Clarion-Ledger via AP) (AP) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f79GaC1s7WCp9r"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="http://www.kait8.com/2018/11/14/challenger-senator-mississippi-hanging-comment-harmful/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="http://www.kait8.com/2018/11/14/challenger-senator-mississippi-hanging-comment-harmful/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fVHFSu1s7WCp9r"> <div id="ad903-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad903" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad903",slotName:"kait/web/politics/national",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"DH2AHXPOZJGCBPLEDOH3BRNUYA"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="fWbr8K1s7WCp9r"> <div class="invisible weather-gradient flex-grid color-white pb-weather night" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="background-grey" data-default-location-code="USAR0304" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="kait" data-location-code="USAR0304" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USAR0304,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="http://www.kait8.com/weather"> <img class="radar-image" src="//webpubcontent.raycommedia.com/kait/wximages/SatRad_DMA_640.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="29" data-temp-c="-2"> 29</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/108_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Jonesboro, AR</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="http://www.kait8.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0M8OPDs7WCp9r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="flcThV1s7WCp9r"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-81516" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2018/11/14/georgia-election-uncertainty-lingers-amid-legal-wrangling-2/"> <img class="width-full " alt="Judge rules on requests by Abrams campaign" src="http://www.kait8.com/resizer/jcfofYW9sdZ6LbmfVSJmuaETTmU=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/5HVQBRRBO5GDLLPDO73EAXMT2I.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/14/georgia-election-uncertainty-lingers-amid-legal-wrangling-2/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Judge rules on requests by Abrams campaign</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Unofficial results in one of the nation's hottest midterm contests give Republican Brian Kemp a slim majority. But Democrat Stacey Abrams maintains that enough uncounted absentee, mail-in and provisional ballots remain to force a Dec. 4 runoff and keep alive her bid to become the first black woman i</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2018/11/15/latest-vermont-dems-cancel-avenatti-events-after-arrest/"> <img class="width-full " alt="The Latest: Avenatti released after domestic violence charge" src="http://www.kait8.com/resizer/vqs1lsoU_C_90FbSDBzfSTjuE0s=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/GJEQWC6ZGRHHTDCS6WDCVIAQUY.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/latest-vermont-dems-cancel-avenatti-events-after-arrest/"> The Latest: Avenatti released after domestic violence charge</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Michael Avenatti has been released from police custody following his arrest on a felony domestic violence charge in Los Angeles</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0dGl5Us7WCp9r"> <div id="ad923-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad923" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad923",slotName:"kait/web/politics/national",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"DH2AHXPOZJGCBPLEDOH3BRNUYA"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0nuMc1s7WCp9r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="f0rVQZOs7WCp9r"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-155136" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/15/official-michael-avenatti-los-angeles-police-custody/"> <img class="width-full " alt="Michael Avenatti arrested in LA on domestic violence charge" src="http://www.kait8.com/resizer/lgX9VW05mgeGVBSKrm2JgErN_LQ=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/Q3TLY62S2RHB3NBFGGJULPMQVQ.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/official-michael-avenatti-los-angeles-police-custody/"> Michael Avenatti arrested in LA on domestic violence charge</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>MICHAEL BALSAMO&nbsp;and</span> <span>ANDREW DALTON</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 3h at 7:43 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/14/judge-ballot-counters-racing-election-finale-maine/"> <img class="width-full " alt="Judge, ballot counters racing to election finale in Maine" src="http://www.kait8.com/resizer/Bu8vRjr3003sjVhfzL2Zoz1AkZw=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ZJOQ6DQS6ZHEFHTJVN4MEL5ACE.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/14/judge-ballot-counters-racing-election-finale-maine/"> Judge, ballot counters racing to election finale in Maine</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>MARINA VILLENEUVE&nbsp;and</span> <span>PATRICK WHITTLE</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 5h at 5:38 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/15/draft-epa-study-finds-newer-nonstick-compound-may-be-harmful/"> Draft EPA study finds newer nonstick compound may be harmful</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>ELLEN KNICKMEYER&nbsp;and</span> <span>JONATHAN DREW</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 5h at 4:52 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/14/utah-republican-behind-tight-race-sues-halt-vote-count/"> <img class="width-full " alt="Utah Republican behind in tight race sues to halt vote count" src="http://www.kait8.com/resizer/_xZzzKFPMb4gxJBlrHEQ0aK0K6c=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/ER3AXELVKRA2HOUECABMUYVOJY.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/14/utah-republican-behind-tight-race-sues-halt-vote-count/"> Utah Republican behind in tight race sues to halt vote count</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>LINDSAY WHITEHURST</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 3:18 PM at 3:18 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fAxTV22s7WCp9r"> <div id="ad209-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad209" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad209",slotName:"kait/web/politics/national",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"DH2AHXPOZJGCBPLEDOH3BRNUYA"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fwuHDX1s7WCp9r"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.kait8.com"> <div class="logo logo-slim"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 472 CR 766<br/>Jonesboro, AR 72401<br/>(870) 931-8888 </p> <a class="call-to-action uppercase color-white" href="http://www.kait8.com/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/kait" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@kait8.com" class="color-white">publicfile@kait8.com <br/> (870) 336-1817</a></li> <li><a href="http://webpubcontent.raycommedia.com/kait/PDF/latestKAITEEO.pdf" class="color-white">EEO</a></li> <li><a href="http://www.kait8.com/2018/08/28/kait-closed-captioning-service-support/" class="color-white">Closed Captioning</a></li> <li><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12785-Jonesboro" class="color-white">KAIT 8 Careers</a></li> <li><a href="http://www.kait8.com/2018/08/24/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.kait8.com/2018/08/24/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/Region8News" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/Region8News" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/kait" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@kait8.com" class="color-white">publicfile@kait8.com <br/> (870) 336-1817</a></li> <li><a href="http://webpubcontent.raycommedia.com/kait/PDF/latestKAITEEO.pdf" class="color-white">EEO</a></li> <li><a href="http://www.kait8.com/2018/08/28/kait-closed-captioning-service-support/" class="color-white">Closed Captioning</a></li> <li><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12785-Jonesboro" class="color-white">KAIT 8 Careers</a></li> <li><a href="http://www.kait8.com/2018/08/24/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.kait8.com/2018/08/24/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/Region8News" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/Region8News" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/r0rrvMTr7WCp9r/render.js?v=36'></script>